Point-to-Point Protocol
lastmod 2024-06-09created 2024-06-091 edits
The Point-to-Point Protocol (PPP) is a data link protocol commonly used in networking for direct connections between two communication nodes. The Point-to-Point Protocol provides authentication, transmission with encryption[1], and data compression.
The Point-to-Point Protocol can be used over serial cables, telephone lines, trunk lines, mobile networks, specialized radio links, and optical networks such as SONET. Most ISPs have customers use the Point-to-Point Protocol for dial-up access to the internet. The Point-to-Point Protocol is broadly divided into PPPoE (Point-to-Point Protocol over Ethernet) and PPPoA (Point-to-Point Protocol over ATM), and ISPs use these protocols for DSL internet service.
The Point-to-Point Protocol is generally used as a data link layer protocol, and has been used as an alternative to protocols such as SLIP and LAPB. PPP was designed to work with a variety of network layers such as IP, IPX, NBF, and AppleTalk.
The Point-to-Point Protocol can also be used for broadband connections. RFC 2516 describes PPPoE, a technique for transmitting PPP over Ethernet. RFC 2364 describes PPPoA, which transmits PPP over ATM AAL5.
The Point-to-Point Protocol is described in RFC 1661.