Skip to content
Search

Extensible Authentication Protocol

lastmod 2020-06-27created 2020-06-273 edits

Extensible Authentication Protocol (EAP) is an authentication framework used for network and Internet connections. It is defined in RFC 3748 (formerly RFC 2284) and updated by RFC 5247. EAP is an authentication framework for providing the transport and usage of material and parameters generated by EAP methods. There are many methods defined by RFCs, vendor-specific methods, and new proposals. EAP is not a wire protocol; it only defines the information of the interface and the formats. Each protocol that uses EAP defines a way to encapsulate the user EAP messages within that protocol's messages.

EAP is widely used today. For example, in IEEE 802.11 (Wi-Fi), the WPA and WPA2 standards have adopted IEEE 802.1X (with various EAP types) as the authentication mechanism.

Methods

  • imble out-of-band authentication for EAP (EAP-NOOB)
  • ightweight Extensible Authentication Protocol (LEAP)
  • AP Transport Layer Security (EAP-TLS)
  • AP-MD5
  • AP Protected One-Time Password (EAP-POTP)
  • AP Pre-Shared Key (EAP-PSK)
  • AP Password (EAP-PWD)
  • AP Tunneled Transport Layer Security (EAP-TTLS)
  • AP Internet Key Exchange v. 2 (EAP-IKEv2)
  • EAP Flexible Authentication via Secure Tunneling (EAP-FAST)
  • Tunnel Extensible Authentication Protocol (TEAP)
  • EAP Subscriber Identity Module (EAP-SIM)
  • EAP Authentication and Key Agreement (EAP-AKA)
  • EAP Authentication and Key Agreement prime (EAP-AKA')
  • EAP Generic Token Card (EAP-GTC)
  • EAP Encrypted Key Exchange (EAP-EKE)

See also

Favorite site

author Zer0 sitemap